Announcement

Collapse
No announcement yet.

FSInn/P3d 2.5/Estonia Migration Tool

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • FSInn/P3d 2.5/Estonia Migration Tool

    Hi All,
    I have a wee problem with FSInn. It appears that it cannot connect to anything. When I start FSInnUI the Control Panel pops up as per normal. What is not normal is that the FSInn button and the mCP button at the top of the Control Panel are RED. Also no Servers (Vatsim, Net2, 3, 4 or FSFDT) are shown on the left side of the Control Panel. I am running Win7 x64 (new install, all updates installed), Prepar3d (2.5.19245.0), a lot of ORBBX sceneries, Estonia Migration Tool (2.5.3.873), NO Antivirus, NO anti-spyware. This PC is specifically for Flight Simming.

    I have a second physical drive installed in the same physical PC with FSX Acceleration installed. This is a separate Windows installation and boot drive. I fired that up and tested FSInn and it worked. I could connect to Vatsim and the two other Flight servers that I use.

    I have followed (to the letter) the instructions here (http://board.flights...p3dv2-5-12944-0) and checked against these here (http://forums.vatsim...hp?f=43&t=47063).

    I have added FSInnUI.exe to Windows Firewall Exception and also tried running with the Firewall turned off.

    This PC has no Antivirus as it is purely a Flight Simulator PC.

    I have now come to the conclusion that the only difference IS P3D and Estonia Migration Tool. And the only discernible difference between the FSX and P3D installs is that the FSFDT install did not add the menu item to the Addon Menu in P3D. I have checked that the dll.xml file has the Fscopilot.dll entry and that this is the last entry in the dll.xml file.
    FSFDT is installed in the root of C:\ (C:\FSFDT) and P3D is also installed in the root of C:\ (C:\Prepar3d v2).

    I think I have confirmed that this is definitely a P3D/EMT issue. I have both reinstalled Windows/P3D from scratch and uninstalled EMT, FSInn and FScopilot. Reinstalled EMT and enabled Virtual FSX, then reinstalled FSCopilot and FSInn. Started FSInn and clicked the Chat and then closed FSInn. I started P3D from the Estonia Migration Tool in Legacy Mode. Checked the Addons Menu and FSFDT was present. FSCopilot showed a green light (top left) to say that a FlightSim had been detected (FSX.exe because that is what Legacy Mode launches). Fired up FSInn (NOT from the Addons menu) and it worked!! I then closed FSInn and P3D Legacy Mode. Disabled Virtual FSX then re-enabled Virtual FSX (this is to stop the message "Unknown FS version. Version = 200"). Subsequent starts in Legacy and "Normal" Virtual Mode have not had the Menu entry reappear and FSInn will NOT connect without it.

    I have done many uninstalls, reinstalls and general tinkering but the failure point is ALWAYS when I disable Virtual FSX and re-enable Virtual FSX. Of course FSInn will not connect if I simply click OK when the "Unknown FS version" message appears. I can run in Legacy Mode multiple times but as soon as I try to run in "Normal" P3D mode FSInn will not connect

    I would really appreciate any assistance at this point

    Cheers

    Harry
Working...
X